Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /home/cadetill/domains/cadetill.com/public_html/wp-includes/class-wp-hook.php on line 286
Problem with GMLib v1.x – El blog de cadetill
Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /home/cadetill/domains/cadetill.com/public_html/wp-includes/class-wp-hook.php on line 286
May 122016
 

Warning: Parameter 2 to qtranxf_postsFilter() expected to be a reference, value given in /home/cadetill/domains/cadetill.com/public_html/wp-includes/class-wp-hook.php on line 286

Due to the future closure of google.code, the raw files are no longer available. For this reason and because GMLib uses StyledMarker.js hosted in this servers, GMLib has stopped working.

However the solution is easy: upload this file to another server and do a small changes into the GMLib code.

So, I have uploaded StyledMarker.js to the GitHub GMLib repository. Now, you only need to do this small modification into GMLib:

  • Into .\resources\map.html file replace this url
http://google-maps-utility-library-v3.googlecode.com/svn/trunk/styledmarker/src/StyledMarker.js

by this other

https://rawgit.com/cadetill/gmlib_v1/master/Resources/StyledMarker.js
  • Recreate resource file executing  .\resources\rc.cmd
  • Build (no compile) all GMLib

With this easy steps we have GMLib up to date.

Another option is download the changes from the repository.

Until the next entry!

 

  32 Responses to “Problem with GMLib v1.x”

  1. which way the repository ?

  2. Hola Cadetill, gracias, lo probé y funciona correctamente, eres un capo!!
    Saludos desde Arequipa, Perú

  3. realize esos pasos y me sigue saliendo el cartel de error de sltyledicon..

  4. Works excellent !

  5. I don’t know why but the indicated procedure has no effect.

    As workaround I’ve copied the whole content of .\resources\StyledMarker.js inside map.html

    AND HAS WORKED !!!.

    so cancel src=”https://rawgit.com/cadetill/gmlib_v1/master/Resources/StyledMarker.js”
    and copy and paste StyledMarker.js before the tag

    I know src= … should work (i can see this page from a browser), but it has not been worked for me.

    BTW, I’m using Delphi 7.

    P.S.
    I have downloaded the library from “Here you have the repository https://github.com/cadetill/gmlib_v1
    but I’ve received an error opening GMLibProject_D7.bpg (i’ve copied the old one over this).

    Thank you for the fantastic job.

  6. Hello,
    Since today i have this message on the MegaDemo.exe

    Oops! Something went wrong.

    This page didn’t load Google Maps correctly. See the JavaScript console for technical details

    if u put a api key it tell me ‘No esta activo’
    Thx for the help !

  7. My project that uses version 1.5.3 of gmlib, are not working I created a Key and put it in the Maps component of Gmlib but it still does not work?

    I saw some messages that have to put the key in the maps.html and recompile the resource file and reinstar the component is this?

    Do you know how I should proceed to solve this problem?

    Thank you

  8. Estimado Cadetill

    Hoy tuve el problema antes mencionado por Jean, descargue los fuentes del repositorio, reconstrui los package y luego recompile la MegaDemo, y sucede lo siguiente:

    1) Al reconstruir los package y compilar la MegaDemo, se despliega “Error Script”.

    Linea: 0
    Carácter: 0
    Error: Script error
    Código:0
    URL: http://maps.google.com/maps-api-v3/api/js/26/17/intl/es_419/common.js

    2) Al reconstruir los “resources” se produce otro error

    Linea: 1486
    Carácter: 19
    Error: No se puede obtener la propiedad “getLength” de referencia nula o sin definir
    Código:0
    URL: about:blank

    Ambiente: Delphi XE7, SO Window 10, x64

    Si tienes alguna luz al respecto te lo agradezco
    Saludos cordiales

  9. I’m having problem to install GMLIB on Berlin. I’m using the GMLibProject_D_Berlin and following the latest install.txt (which has disappeared in the repository) adapting the instructions written for RadStudio XE8 to this new configuration.

    Step n° 1 proceeds ok (compilation and installation of GMLib_D_Berlin) on both 32 and 64 bits
    Step n° 2 (compilation and installation of GMLib_D_Berlin_VCL) fails telling me that GMLib_D_Berlin is not a valid 32 bit package …

    Someone has encountered these problems before me ? A solution exists ?

    Thanks

  10. Siga los procedimientos descritos en el sitio. He realizado el procedimiento de ayer y mi trabajo de nuevo, pero hoy volvió a mostrar el mismo problema error al cargar el mapa.
    ¿Existe un procedimiento de solución final?

  11. Probe de todas las formas recomendadas aqui y sigue apareciendome el error.
    Tuviste alguna novedad mas?

    Gracias,y saludos. La libreria es excelente.

  12. Hello,
    Since today i have this message on the MegaDemo.exe

    “Pagina inicial aun no cargada”
    Exemple from the Megademoexe
    i go to figure then Markers then i choose “camp Nou” then the button Zoom To All and delphi throw that error

    Thx for the help =)

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)

This site uses Akismet to reduce spam. Learn how your comment data is processed.